I don’t have a lot of brand loyalty when it comes to servers and networking infrastructure, but I do have a lot of respect for Dell when it comes to price, and the PowerConnect series is no exception.

ThisĀ  Dell PowerConnect series switches can be an attractive option for SMBs looking to build a core network infrastructure or migrate to a structure based on routed VLANs. Unfortunately, and all due respect to the Dell documentation teams, the documentation for this switch is exceedingly thin.

In the past I’ve covered how to configure stacking and enable an 802.1Q connection to a Cisco switch. One thing I have skipped over though is a very basic initial configuration on the Dell PowerConnect 62xx series switch.

Below is a very basic setup, but it is enough to cover some bare essentials to get the PowerConnect switch connected into an existing management vLAN:



# Setup your basic vLAN database
vlan database
vlan XX

# a few optional / misc config settings
sntp unicast client enable
sntp server
clock timezone -6 minutes 0

# Give your switch an IP and assign it to your vLAN above
ip address
ip default-gateway
ip address vlan XX
ip name-server
ip name-server
# Optional Enable http/https server to connect via web-GUI
ip https server

# Set a Management Username / Password
username “xxxxxxx” password xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx level 15 encrypted

# Pick a port to Set as the Management Port
# Configured to connect to a Cisco Catalyst 3560G
interface ethernet 1/g1
description ’802.1Q C3560G’
spanning-tree disable
switchport mode general
switchport general pvid XX
switchport general allowed vlan add XX
switchport general allowed vlan remove 1


If you’re happy with your settings so far, go ahead and save:

copy running-config startup-config

You will notice above that I haveĀ enabled an 802.1Q connection to a Cisco switch for Ethernet 1/g1. This may not be necessary for your specific configuration, but see my previous blog post for more information if needed.

At this point, you should at least be to the point where you can plug a cable from your existing management network into Ethernet 1/g1 and access the switch on IP If you want to go above and beyond here, you will probably need to refer back to the Dell PowerConnect 6200 series Documentation, but hopefully this was a good enough start.



9 Responses to “Dell PowerConnect 6224 – Basic Configuration”

  1. Diego on May 9th, 2013 7:51 am

    How do I enter the initial configuration of the switch?

  2. Dilip on September 7th, 2013 11:48 am

    Please send me a basic switch config and uplink to cisco switch

  3. mike on September 9th, 2013 3:42 pm


    The basic switch config, including uplink to a cisco switch, is all included above. Simply type the commands and update the relevant information (ie. your IP address and passwords), and you are all set!

    I don’t know your network setup, so I can’t pick an IP for you. Plus, you may want to use a different port for your uplink port. You have the flexibility to change this when using the information posted above.

    Good luck!

  4. Davey on March 7th, 2014 4:08 am

    Great info, and I am grateful that I found it. Thanks for posting this. I am hoping to get some inter VLAN routing up on our 6224 and the Dell Manual isnt a sufficient cover for my inexperience.

  5. Davey on March 7th, 2014 4:10 am

    [ip name-server] command is setting default DNS for the routing functions of the switch?

  6. mike on March 12th, 2014 4:01 pm

    @Davey Correct.

  7. Adam on February 10th, 2015 10:49 am

    What do you need to do – if anything on the Cisco side?

    I configured the port as indicated above on the Dell side – appears we ended up creating a loop in our network.

    We are trying to determine where the issue was. This particular switch (Dell) is supporting our DMZ network, which is on a separate subnet, from Data. Appears Data traffic started to be routed to the IP address on the Dell switch (management port was assigned an IP on the data network so we could reach it).

  8. mike on February 11th, 2015 2:07 pm

    On the Cisco side, I had to include the following configuration on the port:

    interface GigabitEthernet1/0/4
    description 802.1Q DELL POWERCONNECT 6226
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 10
    switchport trunk allowed vlan 10,255,1128,1129
    switchport mode trunk
    switchport nonegotiate
    no ip address
    no mdix auto

  9. Mao Bowdler on June 30th, 2015 2:52 am

    thanks will come back

Leave a Reply