http://blogs.dootdoot.com/mike

Dell PowerConnect 6224 – 802.1Q

Filed Under Uncategorized

This afternoon I called in a favor at work and got some help from Seth with a couple of new Dell PowerConnect 6224 stackable switches we are setting up at work. It was a good excuse to see Seth again, and the favor was greatly appreciated.

Together we debugged a tricky scenario that neither of us saw coming. When we were configuring the switches Management Interface, we were setting up a port to connecting into our existing VLAN via a port on an existing Cisco Catalyst 3560G.

Normally, this should have been nearly plug-and-play, but apparently the Dell PowerConnect 6224 doesn’t support the configuration of a native VLAN in switchport mode trunk.

After some extensive searching, we found a solution. To solve the problem we needed to prevent the switch from discarding untagged frames at ingress. We configured an 802.1Q connection on the Dell PowerConnect using the following commands:

interface ethernet 1/g24
description ’802.1Q C3560G’
switchport mode general
switchport general pvid XX [XX=internal vlan id]
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan remove 1
switchport general allowed vlan add XX untagged [XX=internal vlan id]
exit

No additional configuration was required on the Cisco Catalyst 3560G, however the solution we found online does show some additional commands that could be configured. I’ll post their solution below for future reference, if ever needed.

interface GigabitEthernet1/0/4
description 802.1Q DELL POWERCONNECT 6226
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport trunk allowed vlan 10,255,1128,1129
switchport mode trunk
switchport nonegotiate
no ip address
no mdix auto
end

Ultimately, the configuration worked very cleanly once we found out the problem. I have to give a huge thanks for Seth for not only helping debug this problem, but just for helping out in general. Thanks Seth.

Now all that’s left is to figure out why the two switches aren’t showing up in a single stack…

Comments

6 Responses to “Dell PowerConnect 6224 – 802.1Q”

  1. Dell PowerConnect 6224 – Stacking : dsu | Mike on January 18th, 2011 6:01 pm

    [...] yesterday’s debacle with connecting a Dell PowerConnect 6224 into a port on a Cisco Catalyst 3560G with a native VLAN, [...]

  2. James Smith on October 31st, 2011 6:05 am

    This really is daft, why has Dell done this setup with this switch.

  3. mike on November 1st, 2011 10:00 am

    That is indeed a good question.

  4. Jamie Mwanza on May 11th, 2012 11:34 am

    I need help with the power connect 6224 firmware 3.3.3.3.

    i have created a general mode port from a stacked environment to a non stacked switch. also created an access port on the non stacked switch but i fail to access the machines behind the vlans. where am i going wrong.
    sample config:

    switch port mode general
    switchport general allowed vlan add 100,30 untagged
    switchport general pvid 30

    This config is on the stacked switches.

    on the switch that is not stacked:
    switch port mode general
    switchport general allowed vlan add 30 untagged
    switchport general pvid 30

    i intend to use the access switch for accessing vlan hosts but i am only able to ping the vlan IP.

  5. Nazir on April 9th, 2013 7:57 am

    Thanks for sharing this article. I got one minor question (could be a duff question due to my limited network knowledge).
    Do i have to create following vlans on Cisco swtich:

    10,255,1128,1129

    In other words, do the vlans names and numbers much match on both end of the trunk?

    Thanks in advance

  6. Nazir on April 9th, 2013 7:58 am

    small correction:

    “In other words, do the vlans names and numbers much match on both end of the trunk?”

    thanks in advance.

Leave a Reply